4 Replies Latest reply: Jul 16, 2017 3:01 PM by iraqigeek RSS

32-bit installation of 6.10.8 on Windows 7

iraqigeek Novice

Hi,

I've installed Nessus in a virtual environment on my PC on a Windows 7 VM (32-bit). The installation completed successfully without any error messages, and the browser popped up using HTTP, and asked me to redirect to HTTPS. However, when I try to connect over HTTPS, the connection times out. If I restart the VM, and do a netstat, I see that the nessus service is not listening on 8834. If I uninstsall and reinstall, I'd get the service up and can connect over HTTP but not HTTPS until I restart. I've checked the Windows Firewall configuration and the Nessus installation added two rules there. I've even tried disabling the firewall completely without any success.

 

The VM is running Win7 SP1 without any further updates. I have nmap/zenmap and wireshark installed there and both work without issues. I even tried uninstalling winpcap that wireshark installed (despite being the same version) and letting Nessus install it when it installs. Still no joy.

 

Googling didn't yield any helpful results, nor did going through the Nessus 6.10 manual. Am I missing anything?

  • Re: 32-bit installation of 6.10.8 on Windows 7
    rseguin Master

    Hi Ali,

     

    I've seen this happen when the Nessus interface is binding to an IPv6 address instead of the IPv4 one, so if you go into the adapter settings, disable the IPv6 protocol, then reboot the VM it should work.

    • Re: 32-bit installation of 6.10.8 on Windows 7
      iraqigeek Novice

      Hi Ryan,

       

      Thank you very much for this helpful tip. After disabling IPv6 (on both the network and loopback adapter) and restarting, I could finally get the Welcome page to load. But redirecting to HTTPS still didn't work. However, taking a look inside Event Viewer, I found a couple of error messages under System. Each time I tried to connect using IE, two error messages appeared, both saying "the following alert was generated 10. the internal error state is 10." The source of the error was Schannel. Googling this error, I came across this page, in which was recommending disabling all versions of TLS on IE. Being a .NET developer, I'm quite familiar with the "peculiarities" of IE, and thought I'd try installing Chrome. Voila! HTTPS was now working without issues
      So, in short, disable IPv6, install Chrome/FireFox/Opera/whatever, and restart
  • Re: 32-bit installation of 6.10.8 on Windows 7
    jdavies Apprentice

    IE is supported, however, I've noticed that when upgrading TLS 1.1+ is not automatically check in IE. You need to enable TLS 1.1 and 1.2

    • Re: 32-bit installation of 6.10.8 on Windows 7
      iraqigeek Novice

      Ok. Got it working on IE too, once TLS 1.1 and 1.2 were enabled.

       

      Now, when I perform a scan on the virtual machine's network, Nessus is only detecting the host where it is running, despite having 5 total VMs on this network. All VMs have their firewalls disabled. I can ping all of them, and running a quick scan on nmap (using zenmap GUI) finds all five hosts within a few seconds.

       

      Tried installing it on another VM, this time running 8.1 64-bit, and it's more or less the same. This one detects itself and only one (not the Win7 instance above) of the 5 VMs. Here again, I can ping all 5, and nmap detects them without issue.

       

      Am I missing any configuration in Nessus?